#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).*import.*"
Local $sString = "import backoff" & @CRLF & _
"from service.camera_simple.ffmpeg_dash_loop import rtsp_to_dash_loop" & @CRLF & _
"from share.settings.settings import Settings" & @CRLF & _
"" & @CRLF & _
"from share.types.camera import Camera" & @CRLF & _
"from share.utils.adeck_logging.logging_subprocess import log_process_output" & @CRLF & _
"from share.utils.retry import on_backoff" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")