use strict;
my $str = 'import backoff
from service.camera_simple.ffmpeg_dash_loop import rtsp_to_dash_loop
from share.settings.settings import Settings
from share.types.camera import Camera
from share.utils.adeck_logging.logging_subprocess import log_process_output
from share.utils.retry import on_backoff
';
my $regex = qr/.*import.*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}