re = /<\/?(b|color|i|size)(=.*?)?>/m
str = '<color=#he>x>>
<color=red>>>>
<b>
<i>
</b>
</i>
</color>
<size=13>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end