import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<\\/?(b|color|i|size)(=.*?)?>";
final String string = "<color=#he>x>>\n"
+ "<color=red>>>>\n"
+ "<b>\n"
+ "<i>\n"
+ "</b>\n"
+ "</i>\n"
+ "</color>\n"
+ "<size=13>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}