using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<\/?(b|color|i|size)(=.*?)?>";
string input = @"<color=#he>x>>
<color=red>>>>
<b>
<i>
</b>
</i>
</color>
<size=13>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}