package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<\/?(b|color|i|size)(=.*?)?>`)
var str = `<color=#he>x>>
<color=red>>>>
<b>
<i>
</b>
</i>
</color>
<size=13>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}