$re = '/<\/?(b|color|i|size)(=.*?)?>/m';
$str = '<color=#he>x>>
<color=red>>>>
<b>
<i>
</b>
</i>
</color>
<size=13>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);