re = /^[A-Z][a-z\'\s]+:[A-Z\s]+$/m
str = 'Eminem:VENOM
Linkin park:NUMB
Drake:NONSTOP
Adele:HELLO
Michael Jackson:ANOTHER PART OF ME
Adele:ONE AND ONLY
Guns n\'roses:NOVEMBER RAIN
Christina Aguilera: HuRt
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end