import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[A-Z][a-z\\'\\s]+:[A-Z\\s]+$";
final String string = "Eminem:VENOM\n"
+ "Linkin park:NUMB\n"
+ "Drake:NONSTOP\n"
+ "Adele:HELLO\n"
+ "Michael Jackson:ANOTHER PART OF ME\n"
+ "Adele:ONE AND ONLY\n"
+ "Guns n'roses:NOVEMBER RAIN\n"
+ "Christina Aguilera: HuRt\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}