#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[A-Z][a-z\'\s]+:[A-Z\s]+$"
Local $sString = "Eminem:VENOM" & @CRLF & _
"Linkin park:NUMB" & @CRLF & _
"Drake:NONSTOP" & @CRLF & _
"Adele:HELLO" & @CRLF & _
"Michael Jackson:ANOTHER PART OF ME" & @CRLF & _
"Adele:ONE AND ONLY" & @CRLF & _
"Guns n'roses:NOVEMBER RAIN" & @CRLF & _
"Christina Aguilera: HuRt" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")