$re = '/^[A-Z][a-z\'\s]+:[A-Z\s]+$/m';
$str = 'Eminem:VENOM
Linkin park:NUMB
Drake:NONSTOP
Adele:HELLO
Michael Jackson:ANOTHER PART OF ME
Adele:ONE AND ONLY
Guns n\'roses:NOVEMBER RAIN
Christina Aguilera: HuRt
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);