const regex = /^[A-Z][a-z\'\s]+:[A-Z\s]+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[A-Z][a-z\\\'\\s]+:[A-Z\\s]+$', 'gm')
const str = `Eminem:VENOM
Linkin park:NUMB
Drake:NONSTOP
Adele:HELLO
Michael Jackson:ANOTHER PART OF ME
Adele:ONE AND ONLY
Guns n'roses:NOVEMBER RAIN
Christina Aguilera: HuRt
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}