import Foundation
let pattern = #"[0-9a-f]{8}-[0-9a-f]{4}-[0-9a-f]{4}-[0-9a-f]{4}-[0-9a-f]{12}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Valid
e519f23b-1c3e-5320-8ed0-4c17b8177c05
Invalid
e519z23b-1c3e-5320-8ed0-4c17b8177c05
Invalid
e519-323b-1c3e-5320-8ed0-4c17b8177c0
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)