use strict;
my $str = 'Valid
e519f23b-1c3e-5320-8ed0-4c17b8177c05
Invalid
e519z23b-1c3e-5320-8ed0-4c17b8177c05
Invalid
e519-323b-1c3e-5320-8ed0-4c17b8177c0
';
my $regex = qr/[0-9a-f]{8}-[0-9a-f]{4}-[0-9a-f]{4}-[0-9a-f]{4}-[0-9a-f]{12}/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}