re = /[0-9a-f]{8}-[0-9a-f]{4}-[0-9a-f]{4}-[0-9a-f]{4}-[0-9a-f]{12}/
str = 'Valid
e519f23b-1c3e-5320-8ed0-4c17b8177c05
Invalid
e519z23b-1c3e-5320-8ed0-4c17b8177c05
Invalid
e519-323b-1c3e-5320-8ed0-4c17b8177c0
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end