using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[0-9a-f]{8}-[0-9a-f]{4}-[0-9a-f]{4}-[0-9a-f]{4}-[0-9a-f]{12}";
string input = @"Valid
e519f23b-1c3e-5320-8ed0-4c17b8177c05
Invalid
e519z23b-1c3e-5320-8ed0-4c17b8177c05
Invalid
e519-323b-1c3e-5320-8ed0-4c17b8177c0
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}