import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[0-9a-f]{8}-[0-9a-f]{4}-[0-9a-f]{4}-[0-9a-f]{4}-[0-9a-f]{12}";
final String string = "Valid\n"
+ "e519f23b-1c3e-5320-8ed0-4c17b8177c05\n\n"
+ "Invalid\n"
+ "e519z23b-1c3e-5320-8ed0-4c17b8177c05\n\n"
+ "Invalid\n"
+ "e519-323b-1c3e-5320-8ed0-4c17b8177c0\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}