// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(<nameID aor=\"sip:)(?:\+)?(.*)(@.*)\s(.*)(<name>)(")(.*)(")(<\/name>).*\R(.*)\R(.*)\R(.*)\R(.*)\R(.*)(<apkt:callingParty>false<\/apkt:callingParty>)"#).unwrap();
let string = "<nameID aor=\"sip:+13136622147@sip.quickenloans.com\">
<name>"User 3136622147"</name>
</nameID>
<send>Xcl1Rts4RjtrMBY4Q1IZTQ==</send>
<associate-time>2021-04-20T13:57:07</associate-time>
<extensiondata xmlns:apkt=\"http://acmepacket.com/siprec/extensiondata\">
<apkt:callingParty>false</apkt:callingParty>
<nameID aor=\"sip:3136622147@sip.quickenloans.com\">
<name>"User 3136622147"</name>
</nameID>
<send>Xcl1Rts4RjtrMBY4Q1IZTQ==</send>
<associate-time>2021-04-20T13:57:07</associate-time>
<extensiondata xmlns:apkt=\"http://acmepacket.com/siprec/extensiondata\">
<apkt:callingParty>false</apkt:callingParty>
<nameID aor=\"sip:136622147@sip.quickenloans.com\">
<name>"User 3136622147"</name>
</nameID>
<send>Xcl1Rts4RjtrMBY4Q1IZTQ==</send>
<associate-time>2021-04-20T13:57:07</associate-time>
<extensiondata xmlns:apkt=\"http://acmepacket.com/siprec/extensiondata\">
<apkt:callingParty>false</apkt:callingParty>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}