import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<nameID aor=\\\"sip:)(?:\\+)?(.*)(@.*)\\s(.*)(<name>)(")(.*)(")(<\\/name>).*\\R(.*)\\R(.*)\\R(.*)\\R(.*)\\R(.*)(<apkt:callingParty>false<\\/apkt:callingParty>)";
final String string = "<nameID aor=\"sip:+13136622147@sip.quickenloans.com\">\n"
+ " <name>"User 3136622147"</name>\n"
+ " </nameID>\n"
+ " <send>Xcl1Rts4RjtrMBY4Q1IZTQ==</send>\n"
+ " <associate-time>2021-04-20T13:57:07</associate-time>\n"
+ " <extensiondata xmlns:apkt=\"http://acmepacket.com/siprec/extensiondata\">\n"
+ " <apkt:callingParty>false</apkt:callingParty>\n\n"
+ "<nameID aor=\"sip:3136622147@sip.quickenloans.com\">\n"
+ " <name>"User 3136622147"</name>\n"
+ " </nameID>\n"
+ " <send>Xcl1Rts4RjtrMBY4Q1IZTQ==</send>\n"
+ " <associate-time>2021-04-20T13:57:07</associate-time>\n"
+ " <extensiondata xmlns:apkt=\"http://acmepacket.com/siprec/extensiondata\">\n"
+ " <apkt:callingParty>false</apkt:callingParty>\n\n"
+ "<nameID aor=\"sip:136622147@sip.quickenloans.com\">\n"
+ " <name>"User 3136622147"</name>\n"
+ " </nameID>\n"
+ " <send>Xcl1Rts4RjtrMBY4Q1IZTQ==</send>\n"
+ " <associate-time>2021-04-20T13:57:07</associate-time>\n"
+ " <extensiondata xmlns:apkt=\"http://acmepacket.com/siprec/extensiondata\">\n"
+ " <apkt:callingParty>false</apkt:callingParty>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}