using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<nameID aor=\""sip:)(?:\+)?(.*)(@.*)\s(.*)(<name>)(")(.*)(")(<\/name>).*\R(.*)\R(.*)\R(.*)\R(.*)\R(.*)(<apkt:callingParty>false<\/apkt:callingParty>)";
string input = @"<nameID aor=""sip:+13136622147@sip.quickenloans.com"">
<name>"User 3136622147"</name>
</nameID>
<send>Xcl1Rts4RjtrMBY4Q1IZTQ==</send>
<associate-time>2021-04-20T13:57:07</associate-time>
<extensiondata xmlns:apkt=""http://acmepacket.com/siprec/extensiondata"">
<apkt:callingParty>false</apkt:callingParty>
<nameID aor=""sip:3136622147@sip.quickenloans.com"">
<name>"User 3136622147"</name>
</nameID>
<send>Xcl1Rts4RjtrMBY4Q1IZTQ==</send>
<associate-time>2021-04-20T13:57:07</associate-time>
<extensiondata xmlns:apkt=""http://acmepacket.com/siprec/extensiondata"">
<apkt:callingParty>false</apkt:callingParty>
<nameID aor=""sip:136622147@sip.quickenloans.com"">
<name>"User 3136622147"</name>
</nameID>
<send>Xcl1Rts4RjtrMBY4Q1IZTQ==</send>
<associate-time>2021-04-20T13:57:07</associate-time>
<extensiondata xmlns:apkt=""http://acmepacket.com/siprec/extensiondata"">
<apkt:callingParty>false</apkt:callingParty>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}