# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(<nameID aor=\"sip:)(?:\+)?(.*)(@.*)\s(.*)(<name>)(")(.*)(")(<\/name>).*\R(.*)\R(.*)\R(.*)\R(.*)\R(.*)(<apkt:callingParty>false<\/apkt:callingParty>)"
test_str = ("<nameID aor=\"sip:+13136622147@sip.quickenloans.com\">\n"
" <name>"User 3136622147"</name>\n"
" </nameID>\n"
" <send>Xcl1Rts4RjtrMBY4Q1IZTQ==</send>\n"
" <associate-time>2021-04-20T13:57:07</associate-time>\n"
" <extensiondata xmlns:apkt=\"http://acmepacket.com/siprec/extensiondata\">\n"
" <apkt:callingParty>false</apkt:callingParty>\n\n"
"<nameID aor=\"sip:3136622147@sip.quickenloans.com\">\n"
" <name>"User 3136622147"</name>\n"
" </nameID>\n"
" <send>Xcl1Rts4RjtrMBY4Q1IZTQ==</send>\n"
" <associate-time>2021-04-20T13:57:07</associate-time>\n"
" <extensiondata xmlns:apkt=\"http://acmepacket.com/siprec/extensiondata\">\n"
" <apkt:callingParty>false</apkt:callingParty>\n\n"
"<nameID aor=\"sip:136622147@sip.quickenloans.com\">\n"
" <name>"User 3136622147"</name>\n"
" </nameID>\n"
" <send>Xcl1Rts4RjtrMBY4Q1IZTQ==</send>\n"
" <associate-time>2021-04-20T13:57:07</associate-time>\n"
" <extensiondata xmlns:apkt=\"http://acmepacket.com/siprec/extensiondata\">\n"
" <apkt:callingParty>false</apkt:callingParty>")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.