re = /(<nameID aor=\"sip:)(?:\+)?(.*)(@.*)\s(.*)(<name>)(")(.*)(")(<\/name>).*\R(.*)\R(.*)\R(.*)\R(.*)\R(.*)(<apkt:callingParty>false<\/apkt:callingParty>)/m
str = '<nameID aor="sip:+13136622147@sip.quickenloans.com">
<name>"User 3136622147"</name>
</nameID>
<send>Xcl1Rts4RjtrMBY4Q1IZTQ==</send>
<associate-time>2021-04-20T13:57:07</associate-time>
<extensiondata xmlns:apkt="http://acmepacket.com/siprec/extensiondata">
<apkt:callingParty>false</apkt:callingParty>
<nameID aor="sip:3136622147@sip.quickenloans.com">
<name>"User 3136622147"</name>
</nameID>
<send>Xcl1Rts4RjtrMBY4Q1IZTQ==</send>
<associate-time>2021-04-20T13:57:07</associate-time>
<extensiondata xmlns:apkt="http://acmepacket.com/siprec/extensiondata">
<apkt:callingParty>false</apkt:callingParty>
<nameID aor="sip:136622147@sip.quickenloans.com">
<name>"User 3136622147"</name>
</nameID>
<send>Xcl1Rts4RjtrMBY4Q1IZTQ==</send>
<associate-time>2021-04-20T13:57:07</associate-time>
<extensiondata xmlns:apkt="http://acmepacket.com/siprec/extensiondata">
<apkt:callingParty>false</apkt:callingParty>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end