import Foundation
let pattern = #"\/\/([a-zA-Z0-9]+\.)*(?<http_referrer_domain>[a-zA-Z0-9][a-zA-Z0-9-]*?)\.[a-zA-Z]{2,}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
http://mail.google.com/
http://icycanada.com/
https://www.sfo.semrush.com/tracking/overview/2707853.html?domain_1=cyzerg.com&report_mode=domain_1&sort=nq_desc&page=1
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)