package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\/\/([a-zA-Z0-9]+\.)*(?<http_referrer_domain>[a-zA-Z0-9][a-zA-Z0-9-]*?)\.[a-zA-Z]{2,}`)
var str = `
http://mail.google.com/
http://icycanada.com/
https://www.sfo.semrush.com/tracking/overview/2707853.html?domain_1=cyzerg.com&report_mode=domain_1&sort=nq_desc&page=1
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}