re = /\/\/([a-zA-Z0-9]+\.)*(?<http_referrer_domain>[a-zA-Z0-9][a-zA-Z0-9-]*?)\.[a-zA-Z]{2,}/m
str = '
http://mail.google.com/
http://icycanada.com/
https://www.sfo.semrush.com/tracking/overview/2707853.html?domain_1=cyzerg.com&report_mode=domain_1&sort=nq_desc&page=1
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end