// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\/\/([a-zA-Z0-9]+\.)*(?<http_referrer_domain>[a-zA-Z0-9][a-zA-Z0-9-]*?)\.[a-zA-Z]{2,}").unwrap();
let string = "
http://mail.google.com/
http://icycanada.com/
https://www.sfo.semrush.com/tracking/overview/2707853.html?domain_1=cyzerg.com&report_mode=domain_1&sort=nq_desc&page=1
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}