import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\/\\/([a-zA-Z0-9]+\\.)*(?<http_referrer_domain>[a-zA-Z0-9][a-zA-Z0-9-]*?)\\.[a-zA-Z]{2,}";
final String string = "\n"
+ "http://mail.google.com/\n\n"
+ "http://icycanada.com/\n"
+ "https://www.sfo.semrush.com/tracking/overview/2707853.html?domain_1=cyzerg.com&report_mode=domain_1&sort=nq_desc&page=1\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}