import Foundation
let pattern = #"((^MLB|^NHL|^NFL)\..*?\.(at|vs|Vs|VS).*?(720p|1080p).*?(LEViTATE|ACES|720pier|SENDiT))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
NFL.2021.01.03.Raiders.at.Broncos.1080p.HDTV.AAC2.0.H264-720pier
NHL.2020.03.11.New.York.Rangers.vs.Colorado.Avalanche.720p.WEB.H264-SENDiT
MLB.2019.08.19.Colorado.Rockies.Vs.Arizona.Diamondbacks.720p.WEB.H264-ACES
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)