re = /((^MLB|^NHL|^NFL)\..*?\.(at|vs|Vs|VS).*?(720p|1080p).*?(LEViTATE|ACES|720pier|SENDiT))/m
str = 'NFL.2021.01.03.Raiders.at.Broncos.1080p.HDTV.AAC2.0.H264-720pier
NHL.2020.03.11.New.York.Rangers.vs.Colorado.Avalanche.720p.WEB.H264-SENDiT
MLB.2019.08.19.Colorado.Rockies.Vs.Arizona.Diamondbacks.720p.WEB.H264-ACES
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end