const regex = /((^MLB|^NHL|^NFL)\..*?\.(at|vs|Vs|VS).*?(720p|1080p).*?(LEViTATE|ACES|720pier|SENDiT))/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((^MLB|^NHL|^NFL)\\..*?\\.(at|vs|Vs|VS).*?(720p|1080p).*?(LEViTATE|ACES|720pier|SENDiT))', 'mg')
const str = `NFL.2021.01.03.Raiders.at.Broncos.1080p.HDTV.AAC2.0.H264-720pier
NHL.2020.03.11.New.York.Rangers.vs.Colorado.Avalanche.720p.WEB.H264-SENDiT
MLB.2019.08.19.Colorado.Rockies.Vs.Arizona.Diamondbacks.720p.WEB.H264-ACES
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}