use strict;
my $str = 'NFL.2021.01.03.Raiders.at.Broncos.1080p.HDTV.AAC2.0.H264-720pier
NHL.2020.03.11.New.York.Rangers.vs.Colorado.Avalanche.720p.WEB.H264-SENDiT
MLB.2019.08.19.Colorado.Rockies.Vs.Arizona.Diamondbacks.720p.WEB.H264-ACES
';
my $regex = qr/((^MLB|^NHL|^NFL)\..*?\.(at|vs|Vs|VS).*?(720p|1080p).*?(LEViTATE|ACES|720pier|SENDiT))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}