import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((^MLB|^NHL|^NFL)\\..*?\\.(at|vs|Vs|VS).*?(720p|1080p).*?(LEViTATE|ACES|720pier|SENDiT))";
final String string = "NFL.2021.01.03.Raiders.at.Broncos.1080p.HDTV.AAC2.0.H264-720pier\n"
+ "NHL.2020.03.11.New.York.Rangers.vs.Colorado.Avalanche.720p.WEB.H264-SENDiT\n"
+ "MLB.2019.08.19.Colorado.Rockies.Vs.Arizona.Diamondbacks.720p.WEB.H264-ACES\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}