$re = '/(z-index)(.*[:]*)(-1)/';
$str = 'z-index: -1;
z-index: 1;
z-index: 10;
z-index: -1;
z-index: -1;
z-index:-1;
z-index: 9;
z-index : -1;
z-index : -1;
z-index : -1;
-- z-index: -1;
/* z-index : -1; */';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);