package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(z-index)(.*[:]*)(-1)`)
var str = `z-index: -1;
z-index: 1;
z-index: 10;
z-index: -1;
z-index: -1;
z-index:-1;
z-index: 9;
z-index : -1;
z-index : -1;
z-index : -1;
-- z-index: -1;
/* z-index : -1; */`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}