using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(z-index)(.*[:]*)(-1)";
string input = @"z-index: -1;
z-index: 1;
z-index: 10;
z-index: -1;
z-index: -1;
z-index:-1;
z-index: 9;
z-index : -1;
z-index : -1;
z-index : -1;
-- z-index: -1;
/* z-index : -1; */";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}