const regex = /(z-index)(.*[:]*)(-1)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(z-index)(.*[:]*)(-1)', 'g')
const str = `z-index: -1;
z-index: 1;
z-index: 10;
z-index: -1;
z-index: -1;
z-index:-1;
z-index: 9;
z-index : -1;
z-index : -1;
z-index : -1;
-- z-index: -1;
/* z-index : -1; */`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}