import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(z-index)(.*[:]*)(-1)";
final String string = "z-index: -1;\n"
+ "z-index: 1;\n"
+ "z-index: 10;\n"
+ " z-index: -1;\n"
+ "z-index: -1;\n"
+ "z-index:-1;\n"
+ "z-index: 9;\n"
+ "z-index : -1;\n"
+ " z-index : -1;\n"
+ " z-index : -1;\n"
+ "-- z-index: -1;\n"
+ "/* z-index : -1; */";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}