// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^0?7[4-9]{1}[0-9]{8}$").unwrap();
let string = "07901611249
7901611249
7812304777
7812345678
7901123456
07901234567";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}