using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^0?7[4-9]{1}[0-9]{8}$";
string input = @"07901611249
7901611249
7812304777
7812345678
7901123456
07901234567";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}