$re = '/^0?7[4-9]{1}[0-9]{8}$/m';
$str = '07901611249
7901611249
7812304777
7812345678
7901123456
07901234567';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);