const regex = /^0?7[4-9]{1}[0-9]{8}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^0?7[4-9]{1}[0-9]{8}$', 'gm')
const str = `07901611249
7901611249
7812304777
7812345678
7901123456
07901234567`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}