re = /^0?7[4-9]{1}[0-9]{8}$/m
str = '07901611249
7901611249
7812304777
7812345678
7901123456
07901234567'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end