# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^https:\/\/(\w{1,}\-\w{1,}\.|\w{1,}\.|www\.|)interpolis\.nl$"
test_str = ("https://acc5-www.interpolis.nl\n"
"https://interpolis.nl\n"
"https://acc-www.interpolis.nl\n"
"https://acc5-cm-www.interpolis.nl\n"
"https://acc5-taxateurs.interpolis.nl\n"
"https://www.interpolis.nl\n"
"https://www.mijnsupersecretinterpolis.nl\n"
"https://mijnsupersecret.interpolis.nl\n"
"https://mijnsupersecret.interpolis.nl.hackers.ru\n"
"https://mijnsupersecret.neppedomeinen.interpolis.nl\n"
"https://mijnsupersecret.interpolis.nepdomein.nl")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.