package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^https:\/\/(\w{1,}\-\w{1,}\.|\w{1,}\.|www\.|)interpolis\.nl$`)
var str = `https://acc5-www.interpolis.nl
https://interpolis.nl
https://acc-www.interpolis.nl
https://acc5-cm-www.interpolis.nl
https://acc5-taxateurs.interpolis.nl
https://www.interpolis.nl
https://www.mijnsupersecretinterpolis.nl
https://mijnsupersecret.interpolis.nl
https://mijnsupersecret.interpolis.nl.hackers.ru
https://mijnsupersecret.neppedomeinen.interpolis.nl
https://mijnsupersecret.interpolis.nepdomein.nl`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}