#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^https:\/\/(\w{1,}\-\w{1,}\.|\w{1,}\.|www\.|)interpolis\.nl$"
Local $sString = "https://acc5-www.interpolis.nl" & @CRLF & _
"https://interpolis.nl" & @CRLF & _
"https://acc-www.interpolis.nl" & @CRLF & _
"https://acc5-cm-www.interpolis.nl" & @CRLF & _
"https://acc5-taxateurs.interpolis.nl" & @CRLF & _
"https://www.interpolis.nl" & @CRLF & _
"https://www.mijnsupersecretinterpolis.nl" & @CRLF & _
"https://mijnsupersecret.interpolis.nl" & @CRLF & _
"https://mijnsupersecret.interpolis.nl.hackers.ru" & @CRLF & _
"https://mijnsupersecret.neppedomeinen.interpolis.nl" & @CRLF & _
"https://mijnsupersecret.interpolis.nepdomein.nl"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")