use strict;
my $str = 'https://acc5-www.interpolis.nl
https://interpolis.nl
https://acc-www.interpolis.nl
https://acc5-cm-www.interpolis.nl
https://acc5-taxateurs.interpolis.nl
https://www.interpolis.nl
https://www.mijnsupersecretinterpolis.nl
https://mijnsupersecret.interpolis.nl
https://mijnsupersecret.interpolis.nl.hackers.ru
https://mijnsupersecret.neppedomeinen.interpolis.nl
https://mijnsupersecret.interpolis.nepdomein.nl';
my $regex = qr/^https:\/\/(\w{1,}\-\w{1,}\.|\w{1,}\.|www\.|)interpolis\.nl$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}