const regex = /^https:\/\/(\w{1,}\-\w{1,}\.|\w{1,}\.|www\.|)interpolis\.nl$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^https:\\\/\\\/(\\w{1,}\\-\\w{1,}\\.|\\w{1,}\\.|www\\.|)interpolis\\.nl$', 'gm')
const str = `https://acc5-www.interpolis.nl
https://interpolis.nl
https://acc-www.interpolis.nl
https://acc5-cm-www.interpolis.nl
https://acc5-taxateurs.interpolis.nl
https://www.interpolis.nl
https://www.mijnsupersecretinterpolis.nl
https://mijnsupersecret.interpolis.nl
https://mijnsupersecret.interpolis.nl.hackers.ru
https://mijnsupersecret.neppedomeinen.interpolis.nl
https://mijnsupersecret.interpolis.nepdomein.nl`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}