// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"monitoringLayer_amfsData\.(amfs_cartProtectedSpace|amfs_cartWorkspace)_[0-9]_(monitoredKinematics|monitoredStructure|originX|originY|originZ|originA|originB|originC|length|width|height)").unwrap();
let string = "monitoringLayer_amfsData.amfs_cartProtectedSpace_9_height";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}