import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "monitoringLayer_amfsData\\.(amfs_cartProtectedSpace|amfs_cartWorkspace)_[0-9]_(monitoredKinematics|monitoredStructure|originX|originY|originZ|originA|originB|originC|length|width|height)";
final String string = "monitoringLayer_amfsData.amfs_cartProtectedSpace_9_height";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}