using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"monitoringLayer_amfsData\.(amfs_cartProtectedSpace|amfs_cartWorkspace)_[0-9]_(monitoredKinematics|monitoredStructure|originX|originY|originZ|originA|originB|originC|length|width|height)";
string input = @"monitoringLayer_amfsData.amfs_cartProtectedSpace_9_height";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}